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Exchequer V1 Integration – Server Installation 
Background 

This document provides step by step instructions on installing and implementing the Exchequer V1 

Integration. 

The installation is split in to 2 tasks: 

1. Install and Configure the Server side components 

2. Install the clients 

 

Compatibility 

• Exchequer SQL or Pervasive SQL version 7.0.X 

• V1 2013 SP1, 3.5, 3.6 

 

Prerequisites and Assumptions 

There are a number of prerequisites and assumptions that must be satisfied before proceeding with 

the installation (see Technical Pre-Requisites document). These tasks cannot be ignored or it will 

compromise the success of the installation. 

 

Recommendations: 

• The V1 distribution is located on the Exchequer server and shared so it is accessible by the 

clients. 

Assumptions: 

• Apache 2.2X is installed. 
 

Note: If Apache is not present, an MSi can be found in the \Connector\Utils folder 

Install the MSi  and agree to the defaults, when completed, navigate to the following location:  

 C:\Program Files / (x86)\Apache Software Foundation\Apache2.2\conf directory 

Open the http.conf in a text editor and change Listen 80 to Listen 8085, save and restart the Apache 2.2 service. 
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Install and Configure the Server side components 
The V1 software will be cut and licensed once the customer has purchased the software. 

This will be distributed either by CD or uploaded to be downloaded onto the Exchequer Database 

Server. 

Ensure this distribution is accessible to the Exchequer database server 

 

There are 2 main tasks to perform on the Exchequer database server: 

1. Core software installation 

a. Run the V1 iManager 

b. Run the V1 Exchequer Integration Configuration Wizard in server mode 

2. Integration software installation 

a. Run the V1 Exchequer Integration Configuration Wizard in client mode 
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Sub Task 1 - Core Software Installation 

If iManager has already been run and the standard iManager install guide followed to completion, go 

directly to Sub Task 2 - Integration Software Installation. Below is a summary.  

Prerequisites: 

• A SQL database on the Exchequer database server called DbArchive has been created 

• A SQL user V1User exists and is assigned the default database to be DbArchive 

• The V1User SQL user has sufficient privileges (dbowner) to the DbArchive SQL table 

 

If licensed for Exchequer OCR: 

 

• A SQL database on the Exchequer database server called DbCapture has been created 

• The V1User SQL user has sufficient privileges (dbowner) to the DbCapture SQL table 

 

Core Software installation instructions:  

1. Browse to the uncompressed location of the distribution 

2. From the root location, as administrator run the iManager.exe  

3. When prompted, copy the media to a suitable location on the Exchequer database server. The 

default location is C:\V1Home\CD. 

4. Select Server Components 

5. Select and confirm the below settings for each of the components in the tree: 

• Database Configuration 

• Web Server Configuration 

• DbLogin - SQL Server Database 

• DbWebQuery Configuration 

• DbWebRetrieve 

If licensed for Exchequer OCR: 

• DbCapture 

 

6. Click Install 

7. When completed, click Back 

8. Select Client Components 

9. Confirm a suitable path  

10. Select the following clients ONLY by ticking the boxes; 

• DbLogin Admin Console 

• BLOB Type Manager 

 

If licensed for Exchequer OCR 

 

• DbCapture Admin 
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11. Click Install 

12. When completed, click Close 

 

When convenient, restart the Apache instance to which DbWebRetrieve has been applied. 

Now proceed to Sub Task 2 - Integration Software Installation.  
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Sub Task 2 - Integration Software Installation 

Prerequisites: 

• Sub Task 1 has been completed in full 

• Core software has been copied to the C:\V1Home\CD directory 

• Knowledge of the Exchequer company codes to be used in conjunction with the Exchequer EDM 

system 

• You are advised to temporarily disable real-time anti-virus software (such as Symantec Endpoint 

Protection) as this can prevent the execution of scripts required for the connector 

Assumptions: 

• The Exchequer home directory is X:\EXCHQR 

Installing the Integration Software: 

Now that the core components have been installed, they can be built upon using the Exchequer 

Integration Configuration Wizard. 

1. From the location of the distribution \Connector directory, load the Exchequer Integration 

Configuration Wizard.exe as administrator 

2. Select Server Configuration 

3. When prompted, browse to the CurrentSettings.xml file, (located in the C:\V1Home\CD 

directory) click Open in the windows dialogue to select it 

4. All the necessary details about the core installation should be displayed. Confirm they are 

corrected and amend accordingly. 

5. Browse to the mapped drive of the Exchequer home directory 
 

Note: The associated UNC path for the mapped drive should be populated. It is recommended to test whether 

this can be browsed to as it is used throughout the system 
 

6. Click Install 

Note: You may see a number of services stop and restart at this point.   

 

7. When this stage of the installation has completed, you will be prompted to configure the 

customisation: 

• Click the middle Install button, browse to the X:\EXCHQR\V1CODE directory 

• Select V1EXCHEQUERADDON.exe and click Open 

• If prompted, add a description of 'EDM' and click ok. 

• Finally click Save and close. 

8. Return to the Exchequer Integration Configuration Wizard, click Next > to configure the 

Exchequer Companies 

9. As per the prerequisite, for each Exchequer Company, add the corresponding Exchequer 

Company Code in the cell. Then click Add.  

 

Repeat this for every company code in the Exchequer system. 
 

Warning: No validation of the codes can be done at this point of the installation. Ensure you enter the correct 

information. Mistakes / deviation are time consuming to rectify. 
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10. When all codes have been entered, click Apply. 

The server side configuration is now complete, close the Exchequer Integration Configuration 

Wizard. 

 

Now proceed to Sub Task 3 - Integration Software Configuration.  
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Sub Task 3 - Integration Software Configuration 

Prerequisites: 

• Sub Tasks 1 & 2 have been completed in full 

Assumptions: 

• The core installation is in the c:\V1Home directory 

Installation of the Integration Software 

Now the core software and integration components have been installed, there are some final steps 

to complete to ensure the system is ready for use.  

 

1. Load the DbLogin Admin Console as administrator 

2. Select the tick box to the left of the administrator user in the list 

3. Click the User Settings button  

4. Right click on Live in the tree and left click on Add Application 

5. Select dbarchive v3.0 from the list, click Add 

 

If licensed for Exchequer OCR continue, otherwise go to step 10: 

 

6. Again right click on Live in the tree and left click on Add Application 

7. Select DbCapture v3.0 from the list, click Add 

8. Left click DbCapture in the tree; on the right hand pane ensure the AccessLevel is 5 

9. In the ProfilesAllowed field, edit the text so it reads DbCapture,DbCapturePOP 

 

Note: This will give the Administrator user access to both the NONPOP and POP DbCapture profiles. 

 

10. Click Save (User Settings will close.) 

11. Click the DbArchive Table Editor button 

12. Click the Import from XML button  

13. Browse to the c:\V1Home\DbArchive directory and select the tables.xml file, click Open 

 

Note: This may take a few moments, the more companies, the longer it will take to import. 

 
 

14. Close the DbArchive Table Editor 

15. Click the DbArchive Import/Export button  

16. Go to File > Show system tables 

17. Click _LINKS 

18. Click the load button  

19. A warning appears that this may take some time, click OK 

20. Click OK on success 

21. Close the DbArchive Tag Data Import/Export Tool 

22. Click the Email Mappings editor button   

You will now add the mappings necessary for associated documents to populate the 

description field with the subject line of any emails that are archived. Click the Add button 
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and for each of those available (ending ASSOC), mapping against the description field 

(DDESC) and Subject line for each. 

23. When finished, click the Save icon and close the Email Mappings Editor 

 

If licensed for Exchequer OCR continue, otherwise proceed to Sub Task 4 – Exchequer form 

amendments for printing 

 

The DbCapture OCR functionality has the ability to import PDFs automatically so that they can be 

archived along with an Invoice that is then created in Exchequer. (See the DbCapture Crib Sheet for 

usage instructions.) To ensure the right Company is selected and Coding requirement decided, 

perform these additional steps: 

 

24. Navigate to each NONPOP subdirectory off the C:\V1Home\OCRIMPORT directory. Find the 

HF*DbCapture.tag file, open it in any text editor and append the following lines: 

 

COMPANY:ZZZZ01 

CODINGREQUIRED:YES 

 

25. Navigate to each POP subdirectory off the C:\V1Home\OCRIMPORT directory. Find the 

HF*DbCapture.tag file, open it in any text editor and edit the following lines: 

 

The first line in the tag file should display the name of the DbCapture POP profile: 

DbCapturePOP 

 

Now append the following lines: 

COMPANY:ZZZZ01 

IMP_DOC_TYPE:INVOICE 

PROCESS:Convert from [PDN] to [PIN] 

 

26. The ZZZZ01 should reflect the Exchequer company code applicable to the PDF copied into the 

folder. The PROCESS tag should reflect the process you wish to apply to documents imported 

from this folder.  

27. Save the file. 

28. Repeat these steps for each of the tag files in the hot folders that are polled for PDFs meaning 

that any PDFs placed in these locations adhere to the tag file content. 

 

Now proceed to Sub Task 4 – Exchequer form amendments for printing. 
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Sub Task 4 - Exchequer form amendments for printing 

Prerequisites: 

• Sub Tasks 1,2 & 3 have been completed in full 

Assumptions: 

• The company codes present in the system are ZZZZ01 and AAAA02 

• The V1Home directory is C:\V1Home 

 

When printing documents from Exchequer using the Archive Printer driver, they are archived based 

on the formulas specified in the report. 

 

To facilitate this, formulas must be added to each supported report for each Exchequer Company. 

The following pages give instructions on how to configure the formulas for typical documents types 

in Exchequer. 

 

Note: Example formulas for every company installed are in the C:\V1Home\temp\REPORT_FORMULA.txt file 

from which the values required in the instructions can be copied and pasted.* 
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Configuring Reports for Archiving  

Purchase Order Transactions (POR) 

1. Open Exchequer and login as a user with privileges to access the Exchequer Form Designer 

2. Click Utilities > Form Designer 

3. Click the Open button   

4. Select NEWPOR.EFX, click Open 

5. Click the Formula button  

6. In the white formula text box, copy and paste the following*: 
 

""~~!:~~@[$GUI:0]~~@[$TABLE:ZZZZ01PTRANS]~~@[OUTBOUND:1]~~@[OREF:"+DBF[THOURREF]

+"]~~@[ARCHUSER:"+DBF[USNAME]+"] 
 

Note: ZZZZ01 indicates the Exchequer Company Code, PTRANS indicates the Purchase Transaction SQL 

table 
 

7. Click the Format tab 

8. Click the Font button 

9. Select a size of 4 

10. Select a colour of white 

11. Click OK 

12. Click the If button 

13. In the If: cell add the text 
 

PAGENO = 1 
 

14. Click OK 

15. Click OK 

16. You should now see your formula text box on the form. Move it so it is at the top of the form in 

the header section and stretched as wide as possible 

 

 

 

17. Click the Save button  

 

Repeat the above steps logging in for each Exchequer company, so in the above example replacing 

ZZZZ01 with the associated company code, e.g. AAAA02. 
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Sales Invoice Transactions (SIN) 

1. Open Exchequer and login as a user with privileges to access the Exchequer Form Designer 

2. Click Utilities > Form Designer 

3. Click the Open button   

4. Select NEWINV.EFX, click Open 

5. Click the Formula button  

6. In the white formula text box, copy and paste the following*: 
 

""~~!:~~@[$GUI:0]~~@[$TABLE:ZZZZ01STRANS]~~@[OUTBOUND:1]~~@[OREF:"+DBF[THOURREF]

+"]~~@[ARCHUSER:"+DBF[USNAME]+"] 

 

Note: ZZZZ01 indicates the Exchequer Company Code, STRANS indicates the Sales Transaction SQL table 

 

7. Click the Format tab 

8. Click the Font button 

9. Select a size of 4 

10. Select a colour of white 

11. Click OK 

12. Click the If button 

13. In the If: cell add the text 
 

PAGENO = 1 
 

14. Click OK 

15. Click OK 

16. You should now see your formula text box on the form. Move it so it is at the top of the form in 

the header section and stretched as wide as possible. 

 

 

17. Click the Save button  

 

Repeat the above steps logging in for each Exchequer company, so in the above example replacing 

ZZZZ01 with the associated company code, e.g. AAAA02. 
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Nominal Journal Transactions (NOM) 

1. Open Exchequer and login as a user with privileges to access the Exchequer Form Designer 

2. Click Utilities > Form Designer 

3. Click the Open button   

4. Select NOMTXFR.EFX, click Open 

5. Click the Formula button  

6. In the white formula text box, copy and paste the following*: 
 

""~~!:~~@[$GUI:0]~~@[$TABLE:ZZZZ01NTRANS]~~@[OUTBOUND:1]~~@[OREF:"+DBF[CHOURREF]

+"]~~@[ARCHUSER:"+DBF[USNAME]+"] 
 

Note: ZZZZ01 indicates the Exchequer Company Code, NTRANS indicates the Nominal Transaction SQL 

table 
 

7. Click the Format tab 

8. Click the Font button 

9. Select a size of 4 

10. Select a colour of white 

11. Click OK 

12. Click the If button 

13. In the If: cell add the text 
 

PAGENO = 1 
 

14. Click OK 

15. Click OK 

16. You should now see your formula text box on the form. Move it so it is at the top of the form in 

the header section and stretched as wide as possible. 

 

 

17. Click the Save button  

 

Repeat the above steps logging in for each Exchequer company, so in the above example replacing 

ZZZZ01 with the associated company code, e.g. AAAA02. 
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Time Sheets (TSH) 

1. Open Exchequer and login as a user with privileges to access the Exchequer Form Designer 

2. Click Utilities > Form Designer 

3. Click the Open button   

4. Select TIMESHT.EFX, click Open 

5. Click the Formula button  

6. In the white formula text box, copy and paste the following*: 
 

""~~!:~~@[$GUI:0]~~@[$TABLE:ZZZZ01JTRANS]~~@[OUTBOUND:1]~~@[OREF:"+DBF[THOURREF]

+"]~~@[ARCHUSER:"+DBF[USNAME]+"] 
 

Note: ZZZZ01 indicates the Exchequer Company Code, JTRANS indicates the Journal Transaction SQL table 

 
 

7. Click the Format tab 

8. Click the Font button 

9. Select a size of 4 

10. Select a colour of white 

11. Click OK 

12. Click the If button 

13. In the If: cell add the text 
 

PAGENO = 1 
 

14. Click OK 

15. Click OK 

16. You should now see your formula text box on the form. Move it so it is at the top of the form in 

the header section and stretched as wide as possible. 

 

 

17. Click the Save button  

 

Repeat the above steps logging in for each Exchequer company, so in the above example replacing 

ZZZZ01 with the associated company code, e.g. AAAA02. 

 

Now proceed to Configure users for access.  
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Configure Users for Access 
In order that Exchequer users and EDM users are aligned, they must be ‘mapped’ together in both 

systems. For example, if you have 7 users for your Exchequer system; the same 7 users must be 

added to the EDM system. 
 

To do this, the system administrator must familiarise themselves with DbLogin Admin Console which 

is used to configure users. 
 

As per the first Server Configuration task, the DbLogin Admin Console will have been installed on the 

Exchequer database server. 
 

Login in to the Exchequer database server as the same Windows user who originally ran the 

installation. 
 

Launch the DbLogin Admin Console and log in as administrator / administrator. If we assume we 

want to add a user PETE, follow these steps: 

 

1. Click the            button 

2. Click the                        button 

3. Populate the Username matching exactly how it appears in Exchequer. We will assume the new 

user is PETE 

4. Add the Forename, Surname, Email for the user (again it is preferable this is the email address 

for the Exchequer user) and Password 

5. Ensure to un-tick Must Change 

6. Click Add 

7. Click Close 

8. Click the tick box to the left of PETE now in the list 

9. Click the User Settings button  

10. Right click on Live in the tree and left click on Add Application 

11. Select dbarchive v3.0 from the list, click Add 

12. Click Save 

 

Repeat the above steps for every user who requires access to the system. 
 

Note: For users wishing to scan documents, in addition to the above, repeat steps 1 – 10 but select dbscanner 

from the list, click Add and Save. For users wishing to use DbCapture OCR, again repeat steps 1 – 10 but select 

DbCapture from the list, click Add and Save. 
 

 

Exchequer LIVE 

If you are using Exchequer LIVE you MUST follow the instructions to create your Exchequer users 

within DbLogin.  When processing invoices within DbCapture you must also ensure you are logged in 

as a user that exists in the Exchequer company.  

This means that any PIN transactions created via POP / NONPOP processing will have a valid user in 

the Exchequer database and can be sent for approval in Exchequer LIVE.    

Now proceed to Configure User Access Level. 
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Configure User Access Level  

Assumptions: 

• The ‘configure users for access’ section has been completed. 

• Users have been created, one of those users is JAMES 

• There is an Exchequer company ZZZZ01 which has been configured to use EDM 
 

Certain users may only wish to have access to certain document types, for example: I have a user 

JAMES who only has access to Sales Transactions in Exchequer in the ZZZZ01 company. 
 

To ensure this level of access is aligned in the EDM system, the same setup must be configured. 

 

To do this, follow these steps: 

1. On the Exchequer database server, login to the DbLogin Admin Console as administrator 

2. Click the DbArchive Permissions Editor button 

3. Click the Add button and name your access level SALES, click OK 

4. A new column will appear in the interface called SALES and defaults to allow no access. 

5. Locate the ZZZZ01Sales table, click it to highlight it then click the          button 

6. Click the           button to save the access level to the server and close the permissions editor. 

 

The final step is to assign the access level to the user: 

7. Click the tick box to the left of JAMES in the list 

8. Click the user settings icon  

9. From the tree of applications, left click DbArchive 

10. In the panel on the right, note AccessLevel. Click this and select from the drop down the 

required access level, e.g. SALES 

11. Click Save 

 

From now on, JAMES will only have access to the SALES documents. 

Repeat the above steps building your access levels per transaction. 

 

Note: A user can only be assigned one access level at a time so if multiple documents are required, create 

additional access levels naming as appropriate before assignment. 
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Post Installation 
Although the installation process should fully install and integrate the software, it is best practice to 

make the following checks once the Server Configuration process has been completed. 

Assumptions: 

• The server components have been installed to c:\V1Home 

• The Exchequer home directory is x:\EXCHEQR 

• At least 1 company code has been configured and it is ZZZZ01 

 

Integration Checklist 

Server 

1. Ensure when running the TESTCOM utility, the toolkit responds satisfactorily. 

2. Ensure in the x:\EXCHEQR directory the date stamp of ExchSQLDbCreateLib.dll is 16/05/2015 

3. Ensure clients have unrestricted access via TCP/IP to ports 32000*, 31417* and 31418* to the 

server. 

4. Navigate to the c:\V1Home\DbArchive directory and open V1_SETTINGS.def in a text editor. 

Ensure the dba_server variable is set to the DNS of the Exchequer server. 

5. Ensure the EXDRIVE variable is correct 

6. Ensure the UNCPATH variable is set 

 

Note: Doubled up back slashes is normal. 

 

7. Navigate to the c:\V1Home\DbArchive directory and open ZZZZ01PTRANS.def in a text editor. 

Ensure the #INCLUDES path reflects the path to the V1_SETTINGS.def file. 

8. Having run the installation, it is recommended to restart all services to ensure they respond 

correctly. Navigate to the c:\V1Home\utils directory and double click on the restart_services.bat 

to restart all services installed. It is advised to do this as an administrator class user. 

 

Note: * These are the default values and recommended, if they have been changed during installation, alter 

firewall rules as per ports chosen. 

 

Note: If Exchequer OCR has been licensed, repeat steps 3, 4 and 5 but navigate to the 

c:\V1Home\DbCapture\defs directory and open the V1_SETTINGS_OCR.def. 
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Troubleshooting 
During Installation 

Symptom: iManager fails to create the SQL database  

Solution: 

Click on the Database configuration tick box and check the SQL server name and credentials 

are correct. If / when corrected, click Install to try again.  

 

Using the software 

Symptom: I have tried to use DbWebRetrieve for the first time and get an error: 

 

 

Solution:  

Assuming Apache, go into services, right click on Apache service. Click Log On and tick ‘Allow 

service to interact with desktop’ click Apply, OK. When convenient restart the service and try 

DbWebRetrieve again. 
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Updating an Installed Integration 
Using the Exchequer Integration Configuration Wizard, it is possible to add to an existing integration: 

• Add more companies to utilise EDM capability 

• Continue / finish off a partially installed system 

• Update your system with new content 

 

Adding Additional Companies 

 

The Exchequer Integration Configuration Wizard configures those Exchequer companies that wish to 

utilise EDM. 

 

WARNING 

 

The Exchequer Integration Configuration Wizard cannot detect for companies already configured 

in this release. Ensure you have knowledge of those Exchequer companies already configured for 

use with Exchequer EDM before committing to adding new ones. 

 

Should you wish to add more Exchequer companies to the EDM system, follow these steps: 

  

1. From the location of the distribution \Connector directory, load the Exchequer Integration 

Configuration Wizard.exe as administrator. 

2. Select Server Configuration 

3. An existing system will be detected 

4. Select the option to add additional companies.  

5. As per a fresh install add those company codes required, click Apply. When complete, close the 

Exchequer Integration Wizard. 

6. Load the DbLogin Admin Console as administrator 

7. Click the DbArchive Table Editor button 

8. Click the Import from XML button  

9. Browse to the c:\V1Home\DbArchive directory and select the tables.xml file, click Open 

 

Note: This may take a few moments, the more companies, the longer it will take to import. 

 
 

10. Close the DbArchive Table Editor 

11. Click the DbArchive Import/Export button  

12. Go to File > Show system tables 

13. Click _LINKS 

14. Click the load button  

15. A warning appears that this may take some time, click OK 

16. Click OK on success 

17. Close the DbArchive Tag Data Import/Export Tool 
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18. Click the Email Mappings editor button   

You will now add the mappings necessary for associated documents to populate the 

description field with the subject line of any emails that are archived. Click the Add button 

and for each of those available (ending ASSOC), mapping against the description field 

(DDESC) and Subject line for each. 

19. When finished, click the Save icon and close the Email Mappings Editor 

20. To complete the process, follow the steps in sub task 4 per company added. 

 

If licensed for Exchequer OCR: 

 

21. The additional company / companies will also need adding to the DbScanner OCR profile. 

Consult the section in the Client Installation instructions labelled ‘Add Exchequer OCR Scan 

Profiles into DbScanner’ replicating the steps starting at point 23. 

 

Completing an Unfinished Install 

Although not recommended, if you decide to close the Exchequer Integration Configuration Wizard 

part way through the install, this option allows you to continue from where it left off. 

 

Updating your system with new content 

If the customer has purchased this release whilst already having a previous release installed, clicking 

Update will update their system with the enhancements and bug fixes as per the release note. In 

addition, if OCR is also detected on the distribution, this will also be added to the existing system. 

Instructions to do this continue on the next page. 
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Adding DbCapture to an existing installation 
If you have purchased this release as an upgrade from a previous release and wish to use OCR 

functionality you will need to add DbCapture to your existing V1 core software installation prior to 

running the Exchequer Integration Configuration Wizard.   

Prerequisites: 

• The latest distribution including DbCapture has been copied to the Exchequer server 

• You have your ABBYY Finereader license to hand 

• A SQL database on the Exchequer database server called DbCapture has been created. 

• The V1User SQL user has sufficient privileges (dbowner) to the DbCapture SQL table 

Server Installation Instructions: 

1. Browse to the location of your existing V1 Core software installation 

2. Copy current settings.xml from C:\V1Home\CD, and paste into the root of the latest distribution 

3. From the root of the distribution, as administrator run iManager.exe 

4. Select Server Components  

5. The Server installation screen is displayed, confirm all currently installed Server components are 

shown with a green tick, and DbCapture components which are not currently installed are 

available for selection 

6. Under the DbCapture section, tick Server Instances, and PDF file watcher (to install PDF file 

watcher you will need to configure at least one folder location) 

 

If you have already extracted and installed ABBYY Finereader please skip to Step 12 

 

7. Click on Extract Finereader 

8. A window ‘Locate ABBYY Finereader setup’ is displayed. From here browse to the latest 

distribution on the server and the DbCapture folder, within here you can select the ABBYY10 

setup file 

9. Click Open 

10. The ABBYY10 setup file will then be extracted.  This may take a few minutes. 

11. Press Ok  

12. You are now ready to proceed with the installation , click the Install button 

 

If you have already activated your ABBYY license, please skip to Step 18 

 

13. A message appears prompting you to Launch ABBYY License Manager, choose Yes (if you do not 

activate your license before proceeding, the installation will not complete successfully and you 

will be unable to use the DbCapture components of the software) 

14. The ABBYY SDK 10 License Manager is launched. Click the Activate License button 

15. Enter your license serial number into the fields provided and press Next 

16. You will then be presented with a number of methods of activating your ABBYY license, choose 

the most appropriate option for you and proceed with Activation.  

17. Once your ABBYY License is activated you should close the ABBYY License Manager. This will 

prompt the installation to continue automatically.  
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18. When completed, click Back 

19. Select Client Components 

20. Confirm a suitable path  

21. Select the DbCapture Admin client by ticking the box 

22. Click Install 

23. When completed, click Close 

 

Client Installation Instructions: 

 

You will need to install the DbCapture clients on your client workstations. 

 

1. Browse to the server share location for the latest distribution  

2. Run the iManager.exe as administrator from the share 

3. Select Client Components 

4. Select and confirm the settings for each of the components in the tree below: 

• DbCapture 

• DbCapture Admin 

• DbCapture Interactive 
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DbCapture Configuration Instructions: 

 

Now you have added the DbCapture components to your installation, in order to use DbCapture you 

will need to perform some further configuration 

  

1. Log in to DbLogin Admin Console as the administrator 

2. From the Application menu select Manage Application 

3. Click the Import button 

4. Click Browse 

5. Browse to the latest distribution and the DbCapture folder  

6. Select the XML schema file dbcapture.v.3.0 and press Open 

7. Press Ok to add the application schema to the list  

8. Close the Import Application Schema window 

9. In the Application Management window press Add 

10. In the Add Application window tick the box next to dbcapture v3.0 and press Ok 

11. Press OK on Message box 

12. DbCapture is now displayed in the Environment / Application Structure list 

13. Select DBCapture in the Environment / Application structure and click the Servers button 

14. Click the Add button – a new grid line is created 

15. Enter a Description of DbCapComms Admin Client 

16. Ensure Active is ticked 

17. In the Host field enter your server name or IP address 

18. In the Port field enter 31451 

19. In the Tags field enter CapAdmin 

20. Click the Add button again – this creates another new line 

21. Enter a Description of DbCapComms Interactive Client 

22. Ensure Active is ticked 

23. In the Host field enter your server name or IP address 

24. In the Port field enter 31450 

25. In the Tags field enter CapClient 

26. Click the Add button again – this creates a third line 

27. Enter a Description of DbCapComms Util Client 

28. Ensure Active is ticked 

29. In the Host field enter your server name 

30. In the Port field enter 31452 

31. In the Tags field enter CapUtil 

32. Press Save 

33. Press Ok 

34. Close Application Management 

35. Close DbLogin Admin Console 

 

In order to access DBCapture you will need to add in the Client Access Licenses 

 

36. Navigate to the latest distribution and \Core Files\DbLogin Files\CALS 
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37. Copy the .cal files for DbCaptureAdmin and DbCaptureClient 

38. Browse to C:\V1Home\DbLogin\CALS and paste in the .cal files 

39. Restart the service DBLogin Server service 

40. Load the DbLogin Admin Console as administrator 

41. Go to Users, then Manage Access Tokens 

42. You will see DBCaptureAdmin and DBCaptureClient have been added to the Client Access Token 

List, the Total Tokens should reflect the License you purchased. 

43. Press Close 

 

You will now need to add the DbCapture application to your administrator user  

 

44. Load the DbLogin Admin Console as administrator 

45. Select the tick box to the left of the administrator user in the list 

46. Click the User Settings button  

47. Right click on Live in the tree and left click on Add Application 

48. Select dbcapture v3.0 from the list, click Add 

49. Ensure you select access level 5 and Enable Candidates is ticked. 

50. Ensure ProfilesAllowed is set to DbCapture,DbCapturePOP to allow access to NONPOP and POP 

invoicing processing.  

 

Your Administrator user will now be able to log in to DbCapture admin   

 

The DbCapture OCR functionality has the ability to import PDFs automatically so that they can be 

archived along with an Invoice that is then created in Exchequer. (See the DbCapture Crib Sheet for 

usage instructions.) To ensure your tag files are correct for both NONPOP and POP PDF imports 

please follow the instructions on Page 11, Steps 24-28. 
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Sub Task  - Updating Integration Software 

Prerequisites: 

• DbCapture has been added to the Server installation and correctly configured 

• The latest distribution has been copied to the Server 

• The system is not in use by any Exchequer clients 

 

Updating the Integration Software: 

1. From the location of the distribution \Connector directory, load the Exchequer Integration 

Configuration Wizard.exe as administrator 

2. Select Server Configuration 

3. Press OK 

4. Choose the Update your system with new content radio button 

5. Press Next 

6. Ensure the system is not in use and press Update  

7. Choose Yes when prompted  

 

Note: You may see a number of services stop and restart during the update.    

 

 

Once the update is complete you will be prompted to review the documentation before you 

continue.   

 

 

 

 

 


